WordPress 计划将环境最低要求改为 PHP 5.6 和 MySQL 5.5

2018-12-1908:00:13 12 180
摘要

从最近云服务器的普及速度和程度看,IDC圈子的变革还是非常快速的,这也就使得服务器网站环境的版本跟进得到了保证,所以,WordPress官方的这个计划也是符合现状的。

从官方得到消息,WordPress 计划将环境最低要求改为 PHP 5.6+和 MySQL 5.5+,具体如下:

对于已经运行 WordPress 5.0 的数百万个站点,85%使用 PHP 5.6 或更高版本。我们最近还发现,显示鼓励用户升级其 PHP 版本的通知非常有效。Yoast SEO 在去年进行了实验,发现网站所有者将其 PHP 版本升级的速度是他们显示通知之前的两倍。

有鉴于此,我想建议在 2019 年 4 月,我们将最低 PHP 版本要求提高到 5.6。选择保留在 5.5 或更低版本的网站仍会收到安全更新和可能的错误修复,但在升级到支持的 PHP 版本之前无法升级到最新的 WordPress 主要版本。

同样,我想建议在 2019 年 4 月,我们将最低 MySQL 版本要求提高到 5.5。98.5%的 WordPress 5.0 网站使用的是 MySQL 5.5 及以上版本。

根据反馈和有效性,我们可以通过在 2019 年 12 月前将所需的 PHP 版本提升到 7.0+。

其实,从最近云服务器的普及速度和程度看,IDC 圈子的变革还是非常快速的,这也就使得服务器网站环境的版本跟进得到了保证,所以,WordPress 官方的这个计划也是符合现状的。

 

历史文章推荐:

  • 打赏明月一下下
  • 多谢您的赞赏!
  • weinxin
  • 本博客小程序
  • 微信内浏览本博客
  • weinxin

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen:

目前评论:12   其中:访客  6   博主  6

    • boke112导航 9

      好像WordPress建议配置是PHP7.2和MySQL5.6

      • 树懒 先生 5

        昨天发现我博客的一篇文章被偷盗了,我已经计划给图片加水印了,明月大佬怎么不给图片加水印

          • 明月登楼  博主

            @树懒 先生 因为没有多大意义,文章被盗其实也是一种转载和外链建设!

              • 树懒 先生 5

                @明月登楼 什么版权都没有保留,图片中树懒先生的字样还被遮盖,恐怕这就算是偷盗了吧

                  • 明月登楼  博主

                    @树懒 先生 呵呵,纠结这个容易让自己情绪低落,我从来不管别人怎么转载,我只专注于输出!

                      • 树懒 先生 5

                        @明月登楼 那没有注明出处,何况我的文章都没有收录,岂不是成了别人的原创了!

                        • 明月登楼  博主

                          @树懒 先生 搜索引擎没有那么弱智的!至少谷歌分得清楚谁是原创!这点儿我可以肯定的!至于说百度和国内其它搜索引擎,说实话关注很少不了解!

                          • 树懒 先生 5

                            @明月登楼 百度真的太垃圾了,熊掌号收录了,百度都不收录…大写的服!

                            • 明月登楼  博主

                              @树懒 先生 呵呵,熊掌号还死翘翘了!